System Requirements

FastDup literally work well on a minimally low server configuration. However, it is important to note that the overall best performance of any WordPress plugin would be achieved through a well optimized server configuration. Some of the other minimum requirements include the following:

  • Supported web servers; Nginx, Apache, LiteSpeed, Lighttpd, IIS, uWSGI and WebServerX.

  • MS Edge, Firefox, Safari or Chrome for admin panel.

  • Configurable maximum execution time for PHP

  • WordPress 3.5+

  • PHP 5.3+